OpenSync

Home Forums OpenSync Terminal Server 2008R2 OSRun unable to find the task

This topic contains 6 replies, has 3 voices, and was last updated by  Tim 3 years, 10 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #12732

    Tim
    Participant

    Hello. I just purchased OpenSync.

    I am having issues using OSRun to call a task. My situation is as follows:

    We are running Quickbooks Enterprise 15 Accountant on a Server2008R2 terminal Server.

    Encountered Problem:
    I try to run osrun.exe taskname but get error: taskname is not a valid task name (with & w/o quotes).
    I have tried this both in the OpenSync logon session as well as the administrator login and also a scheduled task running as OpenSync highest privilege.

    Details of actions taken:
    I originally installed OpenSync trial on the Administrator Logon for testing.
    I then created an OpenSync Logon and reinstalled OpenSync on that logon. This did not appear to make any difference as all the tasks were still there.
    I created a connection to a SQL server running on a different machine where I had created an empty DB having OpenSync create tables.
    I connected to QB file as admin and approved OpenSync.
    I created a manual task and was able to run it without issue (QB did not open). During the trial QB would need to be open but now it does not seem matter. Other users had the file open during this.
    If QB was open without the QB file being loaded the manual task would not run saying accountant edition was required in order to open 2 files
    I scheduled the manual task. It ran without issue with osrunner.

    Additional issue:
    Aside from the osrun error I need the schedule to survive a reboot. I attempted to use AlwaysUP to launch osrunner.exe as it will log in the user session and launch an exe after a reboot however the osconfig window crashes if I use Alwasyup to start osrunner within the logged in user context. I will now try to use the task scheduler and a startup script to log in the user session on a reboot.

    I prefer to use the task scheduler with osrun as opposed to osrunner as I also need to be able to call a manual sync from my application.

    Please let me know if you have any suggestions on getting OSRun to call the task correctly as well as any other advice for my deployment.

    #12735

    Yair
    Participant

    we had some issues that OSrunner get stuck or crashes, I built a script that in general check every 3 minutes if that OSrunner run successfully, if not it will kill all Pid’s that is related ( quickbooks and Osrunner )
    and then restarts the service..

    using Cscript (VBA) and command prompt to do this.

    it is desktop interactive I guess you will need to set automatic login after reboot.

    I used this script for over a year and since then, never an issue and with Opensync every 60 seconds quick-book company file. out company file size is 600MB.

    I think Osrunner or quickbook crash/get stuck, on an average of 8 times a day.

    Below is how you should run OSrun.exe without quotes.

    popinv = the task you created with the Open Sync Configurations.

    #12745

    Tim
    Participant

    Thanks for the post. The main problem is really that osrun says that the task name is invalid and with therefore not run anything. I tried creating a new task just now. It will run from the GUI but not from the command line.

    #12748

    Tim
    Participant

    I tried opening the GUI from the Administrator login where I originally installed OS and the tasks are not listed. Neither is the Database or Company File.

    After searching the hard drive I found 2 different osconfig.xml files
    C:\Users\opensync\AppData\Local\VirtualStore\ProgramData\Synergration\OpenSync
    C:\ProgramData\Synergration\OpenSync
    I copied so both files are the same and am now able to call the task from osrun.exe
    However it was giving a path/file access error.
    Running osrun from an elevated command prompt solved this problem despite the user having permission to access the file.

    Several users on the terminal server have Quickbooks open. At no point did I need to have Quickbooks open in order for the task to run.

    Hope these experiences may help other users.

    #12751

    Tim
    Participant

    It would be good to know how to get one set of configs for everyone. I need to copy the config each time I make a change. Deleting the appdata one just recreates it on next exit.

    #12770

    Tom Crawford
    Keymaster

    The root of this problem is in the way Windows virtualizes the default Program Data directory under terminal services. When you log into Windows on the physical machine, the default data folder is c:\Program Data. When you log in remotely, windows virtualizes this to the folder: C:\Users\%UserName%\AppData\Local\VirtualStore\ProgramData.

    Beyond this, OpenSync consists of three executables, two of which are legacy applications that are restricted from accessing C:\Program Data when Windows is running in its default security configuration. These applications are:

    OSConfig2.EXE – The main configuration application – a legacy app
    OSRunner.EXE – The background task that kicks off scheduled tasks – a legacy application
    OSRun.EXE – The command line utility to run a task – Non legacy app

    We are working on converting all of the applications to .NET so they will be managed applications and can access the C:\Program Data folder. In the mean time, we have implemented the following workaround:

    1. Create a folder in the root of drive c for the OpenSync data for example: C:\OSData
    2. Make sure the folder allows everyone full control
    3. Open a command window and type SET followed by enter
    4. Find the environment variable named APPDATA. This will point to a folder on the machine
    5. In this folder, create a file named Synerg.INI
    6. In this file create the following two lines:
    [Default]
    DataPath=C:\OSData (The name of the folder you created in step 1)
    7. After you restart OpenSync, it will create the OSConfig.XML and OSStatus.XML files along with the Logs subfolder within this folder. You can then copy your OSConfig.XML file from its current location to restore your configuration.

    #12828

    Tim
    Participant

    Thanks for the post.

    I have followed these instructions. It did ask me to re-register the software which went fine.
    I did have several event ID 1000 errors referencing dhcpcsvc.dll (each time I tried to run osconfig). I tried removing the xml files but kept getting the error.
    I reversed the procedure and tried it again and included osstatus.xml as well. I also removed the other config files. This seems to work.

    Appreciate the assistance.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.