OpenSync

Home Forums OpenSync Task error COULD NOT START QUICKBOOKS (no error if logged into QB as Admin)

This topic contains 7 replies, has 2 voices, and was last updated by  Yudel Rosales 6 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #64841

    Adrian
    Participant

    We have been experiencing some issues with the OpenSync sync tasks, the issue is not consistently occurring. The issue is syncs won’t run when someone is using QuickBooks (not always the same user). Have checked that when we receive the error the other logged in user(s) could be doing nothing more than logged into a QuickBooks session, not even any windows or pop-ups open. Receive the error in OpenSync:
    Error: Could not start QuickBooks.: -2147220472
    We were using OpenSync 2.0.69 but have just upgraded and am now running 3.0.25. The version upgrade did not change anything for this issue.

    What I have found is that if I stay logged into QuickBooks as the admin we never have the issue. This is the same account that was used during the OpenSync setup and no users utilize this login. However according to the information provided being logged into QuickBooks should not be required to run tasks. Additionally this ties up one of our QuickBooks Enterprise licenses. How can I identify what is the root cause of this issue so we can go back to not staying logged into a QuickBooks session as the admin so syncs run error free?

    #64845

    Yudel Rosales
    Keymaster

    QuickBooks cannot be opened for any user in order to OpenSync runs any task. Either the user name that OpenSync is using cannot be used for another person to connect to the company (even from another computer) at the same time that OpenSync is running. This is QuickBooks API restrictions not OpenSync’s

    #64848

    Adrian
    Participant

    What you are stating is not true in our instance. No other users are using the QuickBooks Admin login. At times OpenSync tasks run even when others are logged into QuickBooks, but other times we receive the error message as stated. If I log into QuickBooks as the Admin user and minimize QuickBooks, the OpenSync tasks always run error free even when four other QuickBooks users are logged in as well.

    #64849

    Yudel Rosales
    Keymaster

    What you are saying matches with what I said. Other user can connect to the company file with different user name. That is ok. If you open QuickBooks with admin user and OpenSync uses that user and you are not working at the moment, OpenSync will run free error. But if someone uses that user from another computer that will be a problem. Also, if you are running on a terminal server you have to option or you leave QuickBooks opened all the time or you go to File->Options and check on “Enable terminal server patches”

    #64850

    Adrian
    Participant

    Correct, our issue has been when no other users are using the Admin login (that is the one OpenSync uses) we will sometimes get the error. I recently changed the Admin password just to be sure no other user was accidentally utilizing that user session. We are running on a terminal server so I just enabled the “Enable terminal server patches” option.

    #64851

    Yudel Rosales
    Keymaster

    Since you checked that, you don’t have to leaved QuickBooks open. Since you change the password, you have to re-authorize the company file to OpenSync. Remove OpenSync from Integrated applications on QuickBooks(you have to be on single user mode to do this) and go back to OpenSync with the company file opened in QuickBooks. Right click on company the add new company. I know the company is there but it will pop up the authorize windows in QuickBooks follow the same process. OpenSync will tell that the company already exist that it cannot be added again but behind the scene, it did the re-authorization thing.

    #64852

    Adrian
    Participant

    Yes I performed all those steps the other week to re-authorize OpenSync when I changed the password. So far it does appear the “Enable terminal server patches” option has indeed resolved my issue.
    Thank you

    #64853

    Yudel Rosales
    Keymaster

    Glad to hear that. You are very welcome.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.