OpenSync

Home Forums OpenSync Sync is getting stuck on reading certain tables from Quickbooks

This topic contains 1 reply, has 1 voice, and was last updated by  David Kite 1 year, 7 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #65604

    David Kite
    Participant

    Hello!

    A little background. I have two QuickBooks files. I sync almost all of the tables from one (The first or Main file) to MS SQL and just invoices and sales orders form the other QB file (The second file). I am running OpenSync 3.0.25 and QuickBooks Enterprise 19 with the latest patches. I sync to a SQL server 2014 SP3 with latest patches. My QuickBooks files are VERY Large, around 2.5 GB each. OpenSync is installed on windows server 2012 R2 fully patched.

    I have had this configuration up and running for several months, since upgrading to QB 19, with no issues.

    Yesterday, the sync process (run from osrun.exe command line) just got stuck on the invoice table on the second QB file (the one that only syncs SO and Invoices) and stayed there for two hours, until someone let me know it wasn’t syncing. I restarted the process, and watch as it sync the main QB file until it errored on my main QB file:

    Table: Inventory Adjustment 14%
    Error: Query timeout expired InventoryAdjustmentLine err#:-2147217871 field:TxnID: in table inventoryadjustment:-2147217871

    And at that point it terminated the sync process on the main file and went on to the next QB file sync. It got stuck again on the invoice table of the second file. To be clear, it was the QB –> SQL part of the sync of Invoices that got stuck. I turned of the process that syncs the second QB file and removed the Inventory Adjustment table from the main sync. I had it just syncing the first QB file in my prtocess. That ran great for a few hours, then it started getting stuck on a different table in the main file. I turned of that table and it was fine, then it started getting stuck on another table, always QB –> SQL direction. By then, it was the end of the work day and I suspected there was an issue with my QB file. I ran the QB rebuild process and that cleaned up a bunch of errors with the file. I then tried to run the sync like normal (turned back on the tables I had turned off) and it just got stuck again. I started deleting all of the records from SQL tables that were stuck, one table set at a time, and then doing a populate form QuickBooks for each of those tables. I worked on that until 7:30 AM this morning and had all but one table working perfect on the main QB file sync.

    I emailed everyone what was going on, and went to sleep for a little bit, expecting that everything with the main file was good to go until tonight when I could finish up fixing (populate from QB) the last table and then dive into the second QB file tables. I got a phone call about 10:30 AM saying that items were not syncing. I took a look and found that the invoice table on the main QB file was stuck and had been sitting there since about 9:00 AM. I restarted the process and watched it get stuck again. Currently I am only syncing from SQL –> QB and that appears to be working without issue.

    Anyone else ever see anything like this? Any thoughts on what may be causing the issue? I know it reads the tables from QB, as there is no issue with a populate from QB. I can’t find any errors in the log files when the sync just gets stuck. Any other suggestions would be greatly appreciated.

    Thank You so much in advance!
    David B. Kite

    #65633

    David Kite
    Participant

    Just as an Update, After doing a full “Populate from Quickbooks” on all of the affected tables last week, this appears to have resolved itself. Not sure what caused it in the first place still, but it is working now.

    Thank You
    David B. Kite

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.