OpenSync

Home Forums OpenSync Sort by txn line id option not executing during scheduled task

This topic contains 10 replies, has 3 voices, and was last updated by  Yudel Rosales 1 week, 3 days ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #65174

    Michael
    Participant

    Hello,

    We are currently running open sync version 3.0.25 and quick books enterprise 2018. When using open sync to create new invoices in quickbooks using a scheduled refresh and update task the line ordering is out of order. If we run the same refresh and update task manually the line ordering is correct. We have spoke with Tom Crawford on many occasions to troubleshoot this issue and this has never been resolved. Are you planning on updating this feature to work correctly?

    #65176

    Yudel Rosales
    Keymaster

    Can we do a remote session so you can show me the problem, please?

    #65177

    Michael
    Participant

    Sure. I am available now. I can send you a go to meeting invite if you can give me your email address.

    #65178

    Yudel Rosales
    Keymaster

    I am on eastern time zone. Are you available tomorrow in the morning? Regards,

    #65179

    Yudel Rosales
    Keymaster

    I am on eastern time zone. Are you available tomorrow in the morning? Regards,

    #65346

    LessPaperCo
    Participant

    Hi, Michael,

    Were you able to figure out how to get resolved yet? We’re having the same issue.

    #65347

    LessPaperCo
    Participant

    @yudel – After hours of testing I have figured out what the problem is and, unfortunately, there is nothing we can do on our end as users – it’s a problem with how OpenSync queries the database.

    OpenSync, when pulling estimatelinedetail, invoicelinedetail, etc is not using any ORDER BY in the query. When not using an ORDER BY it is pulling it in the exact order the MySQL returns (“SELECT * FROM estimatelinedetail WHERE IDKEY=’12345′”)… The problem with this is that MySQL does not return the results in the same order that they’re inserted into the DB. You can never rely on the order of something without having an ORDER BY in the query.

    I tested dozens of times and every single time, no matter what I put in SeqNum or TxnLineID columns it ALWAYS came back in the order that is returned when you query the lines without an ORDER BY clause. This should, hopefully, be an easy fix for you. Just have it order by one of those and let us know what which one we should be using.

    If you’d like to do a screen share so I can show you what I mean please email me. My clients are getting pretty upset that we’ve been waiting weeks and haven’t had a fix yet.

    #65352

    Michael
    Participant

    @LessPaperCo We never did get a resolution to this issue but i agree with you that it is not respecting the options set when running on a schedule like it does when running manually. I would like to work this issue out but it is difficult to get in contact with support.

    #65393

    Yudel Rosales
    Keymaster

    @lesspaperco, That really looks like a simple fix. I will look into and I will go back to you. Thanks for your feedback on this matter.

    #65394

    LessPaperCo
    Participant

    @yudel – Thank you for getting back to me. I look forward to hearing back. I’ll let my clients know that you’re looking into it and will hopefully have a fix soon for it. Thanks!

    #65396

    Yudel Rosales
    Keymaster

    Me too. Really appreciate your help here.

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.