OpenSync

Home Forums OpenSync QuickBooks 2019 Issues

This topic contains 7 replies, has 2 voices, and was last updated by  Yudel Rosales 1 month ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #65697

    dbarlow
    Participant

    I have a client who upgraded to QB 2019 and now the scheduled tasks fail every time they run automatically. I get the failure code “Failed: Could not start QuickBooks.: -2147220472”

    However, if I open the OpenSync Configuration tool and run the tasks manually, they run just fine.

    How do I fix this? I don’t think it’s an issue connecting to quickbooks because I’ve checked the settings to make sure that quickbooks allows 3rd party extensions and like I mentioned earlier, the tasks run just fine if they are started manually.

    #65753

    dbarlow
    Participant

    *Bump*
    I still haven’t gotten a response to this issue.

    Automated tasks still fail with the error message”“Failed: Could not start QuickBooks.: -2147220472”
    I can run tasks manually without issue but it’s extremely inconvenient for me and my client.

    The version is 3.0.25.
    Is there a newer version I can install that doesn’t have issues with QuickBooks 2019?

    #65754

    Yudel Rosales
    Keymaster

    Remove OpenSync from your company file. Keep the company file open and run the task. It should prompt the authorization windows again. After that, you should be good to go.

    #65755

    dbarlow
    Participant

    That worked, thank you.

    #65758

    dbarlow
    Participant

    It looks like I spoke too soon. I’m running into the same problem again. Is there any-way to make this solution stick?

    #65769

    Yudel Rosales
    Keymaster

    Make sure when you open the company file in QuickBooks the open file in multi-user mode is unchecked. See attached.

    Attachments:
    You must be logged in to view attached files.
    #65806

    dbarlow
    Participant

    I went ahead and re-followed the instructions while making sure the “open file in multi-user mode” option is unchecked, however it made no difference. I still get this error, “Failed: Could not start QuickBooks.: -2147220472” unless I open quickbooks manually or run the tasks manually.

    #65810

    Yudel Rosales
    Keymaster

    Are you running on a terminal server? If you do. You have to check terminal server patches. Go to File->Options to do so.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.