OpenSync

Home Forums OpenSync OpenSync Errors pop up

Tagged: 

This topic contains 82 replies, has 21 voices, and was last updated by  victor.gonzalez 1 year, 9 months ago.

Viewing 15 posts - 16 through 30 (of 83 total)
  • Author
    Posts
  • #63151

    Mark
    Premium Member

    Hi,

    Reinstalling does not fix this issue.

    We’re using Quickbooks 2016 and Windows Server 2008.

    What can we do to help you in finding and fixing this bug?

    Also… in regards to your comment “That is what I am assuming that is something on your computer. ”

    If you are not a developer I completely understand that you may not be aware of all the details of software development (I am a software engineer, so I know this process very well). Or… if this is what your developers are telling you, I strongly advise that you pass this message along to them for educational purposes.

    Having myself been a developer for more than 20 years, building applications being used by thousands of users in a wide variety of different environments, here’s some rules of thumb that have stuck with me:

    – Just because other people are not reporting this issue, does not mean they are not being *affected* by it. People may see this issue, restart their program, and carry on with their day. People who see this bug, may not be reporting it. Don’t let visual-bias get in the way of properly supporting your software and customers.

    – Just because other people are not reporting this issue. It does not mean that it’s a problem with the local PC. Software behaves differently in different environments. For example, if you only test your application with the latest Quickbooks and the latest Windows Server, you are only testing in ONE environment and biasing your QA and testing. Our environment here, may not be one you have tested with.

    Also, we just experienced the problem today. Same exact error with trying to grab semaphore OSMon2State.

    A quick google on ‘OSMon2State’ only returns this very OpenSync forum post. I would believe it’s a good educated guess to say that this code is specific to OpenSync. I would recommend searching through your codebase for the string ‘OSMon2State’ and checking on how this is used, and also reviewing your testing for handling failure scenarios. In order to debug this, you may not have to replicate my exact scenario. You can write some test code to simulate a failure in initializing this semaphore and then see how your application responds.

    Things to think about:
    Upon semaphore-acquisition failure, does your application properly wait and try again? Does it properly release any resources that other threads may be using, to give them the opportunity to finish their work so your lock can try again ‘from scratch’? (Avoiding deadlocks).

    Based on the results of running into this issue, and seeing that the failure causes hundreds of popups to open, I would make an educated guess that perhaps this *is* a deadlock type issue or other resource-contention problem. Also… while handling this type of failure, I would recommend that instead of doing a simple MessageBox popup each time, that you instead open up a single message-log window and write messages to that instead. This would add for more flexible debugging/logging in the future, so that upon application failures, the users do not have to close hundreds, if not thousands of popups containing the error message.

    I hope this all helps, and I appreciate your fairly quick 3 day response to our issue. I’ve turned on notifications to my email on this post. So when you write back in the future, I’ll be able to communicate back to you more quickly.

    Thanks.

    #64369

    accounting15
    Participant

    I installed version 3.0.20 yesterday and have been experiencing this same issue. Is there a resolution for the pop-ups?

    #64371

    Mark
    Premium Member

    Yes. Please address this issue. We’ve been living with it for a while.

    Do you have any other method of written tech support for this product? Do you have a web ticket or helpdesk system yet? This forums method is really frustrating, because it takes so long to get issues corrected.

    We’re not going to pay for a phone support resolution for something that should work properly already.

    Honestly, if you want… we are a technology company, specializing in communications software. I can assist you with installing any ticket/helpdesk system that you would prefer to use. There’s many open source and free helpdesk support systems, and I would set one up at no charge so that you can improve the customer experience of your entire userbase.

    You do have a great product, and there’s not much in the way of close competition, so you do have the market quite cornered. But, if you would really like to shine in your marketplace. Please improve your customer support options.

    #64372

    ruby.zindler
    Participant

    +1 on this. I did a clean install of 3.0.20 yesterday (upgraded from 2.0.78) and am getting the OSMon2State error like crazy now.

    Attachments:
    You must be logged in to view attached files.
    #64374

    Yudel Rosales
    Keymaster

    Was the pop-ups error showing with the OpenSync 3.0.19 version? or just came out with he new version?
    Did you uninstall previous OpenSync version before install the last one?

    #64375

    ruby.zindler
    Participant

    In my case, I was using a brand new virtual instance of Windows 10 and did a clean install of 3.0.20.
    We upgraded OpenSync along with our migration to QB 2019 and the old version was running on Windows 7. I started fresh in 10 so OS updates will continue for the foreseeable future.

    #64376

    ruby.zindler
    Participant

    I went back into QuickBooks to look at the integrated application permission. The one there was a holdover from the previous version of OpenSync, so I tried clearing out the old permission and allowed OpenSync to reauthorize.
    This seems to have fixed my problem for the moment, but will post back if anything changes. While it makes sense in principle, it is a little strange because I installed and set up OpenSync yesterday and was able to sync our database without issue. It couldn’t have used anything other than the old permissions. Not sure what changed after the scheduled task took over.

    #64377

    Chris Olson
    Participant

    I’ve been having this same error since at least 3.0.17 or so.

    It seems sporadic, but after upgrading to 3.0.20 the error is back.

    I can successfully run any of my tasks manually with no issues. But, when I start the OpenSync task scheduler, I get this error when it attempts to run its first task.

    Attachments:
    You must be logged in to view attached files.
    #64379

    Chris Olson
    Participant

    UPDATE

    I was also noticing a “could not start quickbooks” error occurring constantly, so I went in to single user mode as admin, remove the integrated application permission for OpenSync, restarted the QB server operating system, started QB into single user mode again as admin, started OpenSync, manually ran a small refresh task, which prompted the application authorization dialog from QB, which I completed giving OpenSync full access. Now, the service runs fine and there is no further occurrence of the OSMon2State semaphore error.

    #64380

    Yudel Rosales
    Keymaster

    Can you do the same that Chris Olson did? To see if avoid the issue. So, I can have a better idea how to trouble shooter the issue from my side please.

    #64381

    ruby.zindler
    Participant

    Not sure if you mean me or not, but as I indicated earlier replacing the original integrated application permission in QuickBooks worked for me.

    #64382

    Yudel Rosales
    Keymaster

    That is good to hear that.

    #64387

    dhamm
    Participant

    I get the same error but it’s very random. Opensync can run for months and then all of a sudden it errors out. All that appears in the log is:

    2018-10-18 11:34:31 0 WorkTracker Run Task Refresh QB3
    2018-10-18 11:34:31 0 WorkTracker Starting task: Refresh QB3
    2018-10-18 11:34:31 0 BackWorker ExecuteBackground Begin
    2018-10-18 11:34:37 0 BackWorker MakeQbConnection: Connection Opened
    2018-10-18 11:34:39 0 BackWorker Refresh table Invoice
    2018-10-18 11:34:40 0 BackWorker Refresh table Item Inventory
    2018-10-18 11:34:40 0 BackWorker Refresh table Purchase Order
    2018-10-18 11:34:41 0 BackWorker Refresh table Sales Order
    2018-10-18 11:34:42 0 WorkTracker WorkDone
    2018-10-18 11:34:42 0 BackWorker CloseQbConnection: Close Connection
    2018-10-18 11:34:42 0 BackWorker ExecuteBackground Complete
    2018-10-18 11:35:53 0 OSRunner OSRunner Terminating
    2018-10-18 11:35:54 0 OpenSync:Poller Shutdown
    2018-10-18 11:35:55 0 OSRunner OSRunner Terminating
    2018-10-18 11:35:55 0 OSRunner OSRunner Terminating
    2018-10-18 11:35:55 0 OSRunner Terminating

    The screen shot from Chris Olson is what I get after that and if I don’t notice it, it max’s out memory and cpu.

    #64432

    Frank
    Participant

    We are getting the same error. Tried replacing integrated application permission in QuickBooks without success. Need assistance please!!!

    Frank Agin - AmSpirit

    #64434

    David
    Participant

    I am also having the error “can’t initialize semaphore:OSMon2State” We are on version 3.0.21 and quickbooks 2018. I uninstalled OpenSync and re-added the QB file with no luck. Please advise.

Viewing 15 posts - 16 through 30 (of 83 total)

You must be logged in to reply to this topic.