OpenSync

Home Forums OpenSync Login Timeout Expired

Tagged: 

This topic contains 2 replies, has 3 voices, and was last updated by  becky 4 years, 9 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #16827

    tomk
    Participant

    I am running a task to update my invoices and I sometimes get a timeout when it is running the process. It works most of the time but it seems like when I have a lot of invoices to update it times out. Usually it seems to start running and it will start saying “Record 1 of 56” and then by the time it gets to 40 or so it gives a timeout error.

    Can I change the timeout period? Is that on the SQL server side?

    Thanks,
    Tom Komin

    #16875

    Tom Crawford
    Keymaster

    The timeout is most likely on the SQL server. Please check the coreObjXDB log to confirm this. The timeout is currently fixed at 60 seconds which should be more than enough. You can also check your SQL Server logs to confirm this and potentially discover the root cause of the problem.

    #16891

    becky
    Participant

    I have a similar issue. I have a task setup in Open Sync that is supposed to refresh several tables from QuickBooks to a SQL Server database running on an external server. I have verified that the firewall on the external server allows connections for the Open Sync computer’s IP address on port 1433.

    The task starts with the customers table that has over 14,000 records to refresh. The task runs for awhile (possibly an hour) and then it throws the following error:
    Failed: Login timeout expired vbcrlf _(Please reconnect to your database server and try again.): -2147467259

    I have attempted a variety of connection strings:
    Provider=sqloledb;Data Source=mydatabasedomain.com;Initial Catalog=databasename;User Id=databaseuser;Password=********
    Provider=sqloledb;Data Source=databaseIP;Initial Catalog=databasename;User Id=databseuser;Password=********
    Provider=sqloledb;Data Source=databaseIP,1433;Initial Catalog=databasename;User Id=databaseuser;Password=********
    Provider=sqloledb;Data Source=databaseIP,1433;Network Library=DBMSSOCN;Initial Catalog=databasename;User Id=databaseuser;Password=********;
    Provider=sqloledb;Data Source=databaseIP;Network Library=DBMSSOCN;Initial Catalog=databasename;User Id=databaseuser;Password=********;

    The 2 connection strings with the port number (1433) specified throw a different error:
    ConnectionOpen (Connect()). SQL Server does not exist or access denied.

    When I setup all of the connection strings, I tested the connection through Open Sync and the tests were all successful.

    I tried launching Open Sync with the “Run as administrator” option and running the task.

    I also ran the following SQL queries:
    EXEC sp_configure ‘remote query timeout’, 0 ;
    GO
    RECONFIGURE ;
    GO

    EXEC sp_configure ‘remote login timeout’, 0 ;
    GO
    RECONFIGURE ;
    GO

    I still get the same errors.

    We recently migrated Open Sync to a new Windows 10 computer. The license has been successfully transferred. Since then, I have not been able to get this task to complete successfully.

    Is there something else I need to do to prevent the timeout?

    Thanks.

Viewing 3 posts - 1 through 3 (of 3 total)

The forum ‘OpenSync’ is closed to new topics and replies.