Home Forums OpenSync Inventory Transfer

This topic contains 18 replies, has 3 voices, and was last updated by  marius 3 days, 21 hours ago.

Viewing 15 posts - 1 through 15 (of 19 total)
  • Author
  • #63898


    I am trying to do an inventory transfer and for some reason it was requiring the transferinventorylinedetail to have location settings. If I look at other transactions that came from doing it in quickbooks, none of them require those because the whole transaction is using the locations. So I put the details in to the from and to fields. Now when I run it, I get this “Error Message: This feature is not enabled or not available in this version of QuickBooks” I did some searching and maybe I need to turn on unit of measure or something? I can’t figure it out.



    Update: I believe it’s giving me that error because I populated the location per item in the transferinventorylinedetail table but I really should be leaving those as null. There must have been some other reason it’s not working. I’m thinking maybe opensync doesn’t support transfers?

    I also notice that there is no “Class” setting on the transfer table, where do you pick the Class?



    I really need help on this. The first thing I need to know is if Inventory Transfer is even possible. If so and I have to pay for premium support just let me know and I’ll do that


    To add a “transferinventory”. You will “FromInventorySiteRef_ListID” or “FromInventorySiteRef_FullName”. And “ToInventorySiteRef_ListID” or “ToInventorySiteRef_FullName”. Plus the fields that you want to add that are supported. I hope this helps.



    There is something wrong with Opensync. Here’s what I did. I did a populate from quickbooks to our db. Then I edited 2 fields once it was in the db. I went in to the transfer inventory table and I changed the ref number and then changed it to status=add. Then it gives this error
    Entry required
    2018-07-18 17:07:18

    If I changed nothing but status=add shouldn’t that have worked? I noticed when I populate from QB it doesn’t give me a CLASS field which is strange. Is there something I’m doing wrong?



    I don’t know if your data schema has all of the information needed, I have attached two files. I think the transferinventory table is ok maybe, but the detail table perhaps is missing information. I don’t know but hopefully you can figure it out because there’s a bug

    You must be logged in to view attached files.

    We will look into that. Sorry for the inconveniences.



    I’m having a similar issue. We removed the BINs from quickbooks so now when I post something I don’t have SiteLocations anymore but the transfer fails with:
    -2147211503 transferinventory:transferinventorylinedetail frominventorysitelocation f-1082: Entry required 2018-08-13 11:21:23
    I checked a record that was added from QB and that record doesn’t have anything in FromInventorySiteLocationRef_ListID

    If I leave old data in FromInventorySiteLocationRef_ListID and ToInventorySiteLocationRef_ListID I get

    Please help



    Yeah there must be a bug there. I gave up on Opensync and I just bought Fishbowl Inventory for 10 grand. I couldn’t deal with all the issues and adding a few hundred sales receipts just took way too long. It’s not feasible for a bigger organization and as we grow it will get even worse.


    @marius can you try running a full populate then continue with your regular tasks?



    It’s not really possible to do a full populate since the database is very BIG already and also I’m not sure how would that help my case.
    As I said I’m looking at records that were being added from QB in transferinventorylinedetail and have no record in FromInventorySiteLocationRef_ListID, ToInventorySiteLocationRef_ListID. When I try to add something without any data there I get:
    Table: transferinventory:transferinventorylinedetail
    Error Field: frominventorysitelocation
    Desc: Entry required




    Please I need to get this to work…



    I see a new version of OpenSync but this issue was still not fixed. I need to Post transfers where FromInventorySiteLocationRef_ListID and ToInventorySiteLocationRef_ListID are null.
    Records added through QuickBooks have null on those fields


    If you don’t run a full populate, you probably will continue to have inconsistencies on your database. SO, I will recommend to run a full populate and start fresh.



    I’m sorry that I might not be as technical as you are, but can you explain how would a populate fix my issue? As the initial person in the thread reported, I copied a recorded that was created by QB add status ‘ADD’ to it when I tried to push it it fails.

Viewing 15 posts - 1 through 15 (of 19 total)

You must be logged in to reply to this topic.