OpenSync

Home Forums OpenSync Invalid object name 'history'.:-2147217865

This topic contains 10 replies, has 2 voices, and was last updated by  Yudel Rosales 3 months, 2 weeks ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #65041

    Mike Miazga
    Premium Member

    Just updated Quickbooks from 2016 to 2019.

    New server, windows 2016 datacenter edition.

    Creates new database on sql server.

    Try to populate the new database it fails with this error:

    Invalid object name ‘history’.:-2147217865

    What can I do?

    #65053

    Yudel Rosales
    Keymaster

    Which version of OpenSync are you running?

    #65143

    Mike Miazga
    Premium Member

    3.0.25.

    It’s a brand new server I’ve spun up. It’s trying to use an older version of SQL Server (not the same server).

    I need to get this figured out, it’s been months off and on of trying and the support responses (a week later-and I didn’t get a notification of the response even though it’s checked to do so) aren’t helping. I paid for the advanced support. I really need to get this working ASAP at this point. A screen share may fix it on the spot if you can connect with me.

    #65148

    Yudel Rosales
    Keymaster

    Make sure that the database allows ip connections.

    #65161

    Mike Miazga
    Premium Member

    It’s the same database that works w the previous version. It creates a new database successfully, but fails on the populate so the connection should be ok. Can you point me where to verify?

    #65162

    Yudel Rosales
    Keymaster

    Can you run the task? And sen me the log files, please. Also, make sure that you have that history table on your database.

    #65167

    Mike Miazga
    Premium Member

    There are no tables except system tables in the database that opensync created. I can run the task and it tries, but fails with the invalid object name ‘history’ error every time. If I try to add the existing quickbooks database that is working with the previous version I get the error: Invalid Object name ‘sys.sysdatabases’.

    I’d actually like to get this synced with that existing database if possible. Everything I’m trying as a workaround is failing at the moment however.

    Here are the logs.

    Attachments:
    You must be logged in to view attached files.
    #65169

    Yudel Rosales
    Keymaster

    You need to create the database. then populate it.

    #65170

    Mike Miazga
    Premium Member

    Yes, I’ve done this a number of times. I just did it again. Created database ‘QB_YetAgain’ from Open Sync, it creates it successfully on the remote server (I can see the database in SQL Server on the remote server, I see only system tables in the database) but then when I click on the database in opensync I get the error ‘Invalid Object Name: History’. I’m not really seeing anything of interest in the logs since I sent them to you previously, from creating this database.

    #65171

    Mike Miazga
    Premium Member

    Just saw that the logs failed to upload..

    Attachments:
    You must be logged in to view attached files.
    #65175

    Yudel Rosales
    Keymaster

    I emailed you. We need to do a remote session to see what is going on there.

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.