OpenSync

Home Forums OpenSync Editing Oracle connection string?

Tagged: , ,

This topic contains 7 replies, has 3 voices, and was last updated by  gary.chancellor 10 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #65354

    Cory
    Participant

    I’m currently using a trial version of OpenSync 3.0.25 with the license key for Oracle.

    When I add a database, I am able to connect, and OpenSync created all of the tables in the schema. However, trying to browse the database from OpenSync or attach it to tasks is giving me an ORA-12560 protocol adapter error.

    I need to be able to edit the connection string – I see that in the help documentation for an Oracle database there’s a check box during setup to specify a connection, but I don’t see that on my installation of OpenSync. Is this still an available feature?

    #65366

    Cory
    Participant

    Is there no support for Oracle?

    #65391

    Yudel Rosales
    Keymaster

    Trying editing the connection string for ADBO connection.

    #65400

    Cory
    Participant

    Yudel, are you saying that it’s possible to edit the connection string in OpenSync Configuration? It’s not presented as an option when adding a database, and I don’t seem to be able to edit a Database once it’s been added.

    Where would I go to change the connection string?

    #65433

    Yudel Rosales
    Keymaster

    It is possible manually. Not that you can do it through OpenSync. Go where the configuration file is and right click. Then you can do it all the changes.

    #65589

    gary.chancellor
    Participant

    I am having the same issue. While it captures the connection string correctly and if I use the Test while creating the database, it says it is successful. For anything after that point, it is not using a connection string or an Oracle tns alias because it is instead attempting to use the BEQ driver with a connect string to the database ORCL.

    I have detail client trace logs and it is definitely not using the connection setting from the OSConfig.xml file – it has the correct address as: ‘Data Source=(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=localhost)(PORT=1521))(CONNECT_DATA=(SERVICE_NAME=ORCL)))’. Instead because it does not pass the connection string Oracle is instead defaulting the connection which results in:
    (DESCRIPTION=(ADDRESS=(PROTOCOL=BEQ)(PROGRAM=oracle)(ARGV0=oracleORCL)(ARGS='(DESCRIPTION=(LOCAL=YES)(ADDRESS=(PROTOCOL=beq)))’))(CONNECT_DATA=(SID=ORCL)(CID=(PROGRAM=C:\Program?Files??x86?\Synergration\OpenSync\OSConfig3.exe)(HOST=XXXXXXXXX)(USER=yyyyyyy))))

    I renamed my database to ORCL to see if I could get it to work – that didn’t work either.

    This happens when a client program attempts to connect to Oracle and does not pass a correct connection string or tns alias.

    Any clue if we can change something in the trial to get it to work correctly?

    Regards,
    Gary

    #65636

    Yudel Rosales
    Keymaster

    Have you tried to update the configuration file manually?

    #65644

    gary.chancellor
    Participant

    Yudel,

    Yes. I tried changing settings to effect what I saw in the combined connection string to match the required settings for Oracle ODAC. However, I could not get it to connect. The strange part is that it validates the account and password just fine when creating the Database connection, but won’t sync.

    The connection information shown in the configuration page of the UI is:
    Provider=OraOLEDB.Oracle;dbq=localhost;User Id=[User];Password=*******

    After updating the “DBServer” setting in the XML to match recommended settings I found elsewhere on the internet, the displayed connection in the UI was:
    Provider=OraOLEDB.Oracle;dbq=localhost:1521/ORCL;User Id=[User];Password=*******

    It still wouldn’t connect. I validated the connection string setting in the XML file for “DotNetConnectionString” works when I use it manually to connect with Oracle tools.

    I have also created a special launch batch file for the OSConfig3.exe also to ensure all of the Oracle connection settings are set – but that hasn’t worked either.

    Thanks,
    Gary

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.