Home Forums CoreObjX / DB Could not start QuickBooks

This topic contains 4 replies, has 3 voices, and was last updated by  Philip 1 month ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #13604

    dlaughlin
    Participant

    I’m developing an application that runs fine on a development machine, with IIS Express 8.0, but when I deploy it to a test server, running Win 2012 and IIS 8.0, I get a “Could not start QuickBooks” error when calling Connect(). I’ve also tried it on Win 2008 R2 and IIS 7.0 with no luck. I’ve run the CoreObjX setup on the server and the diagnostics and sample apps run fine. I’ve tried it with and without a company file specified and the results are the same. QuickBooks is already open and I’m logged in as Admin, but I don’t even get the prompt to authorize the application.

    What other things should I be checking to resolve this?

    #13606

    Tom Crawford
    Keymaster

    This is an inherent problem with the QB API, it cannot be called from a system service. As a result, trying to connect to QB from a web application will not work unless you configure coreObjX to run under DCOM and execute as an interactive user. We do not recommend this configuration however since the QB API is very slow and single threaded. This approach will cause your app to run very slow with little scalability. For web based applications we recommend using our OpenSync product which creates a mirror image of the QB data in either a SQL Server or MySQL database. This allows you web based application to run at true database speeds.

    #13617

    dlaughlin
    Participant

    I’m curious why it ran fine from my workstation. Can you explain that to me?

    If speed is not an issue (i.e. the web application initiates an unattended process), how do I go about configuring coreObjX to run under DCOM and execute as an interactive user?

    #13619

    Tom Crawford
    Keymaster

    I suspect the IIS Express is running as an interactive user account.

    Unfortunately, we cannot support you with this configuration with any more information than we have already provided. At best this will be a very slow configuration and I suspect it will be rather unstable.

    #65920

    Philip
    Participant

    I cannot get the automated process to work unless I am logged into the machine AND running QB as Admin. I have tried setting up a Task Scheduler Job with OSRun.exe <taskname>, I have tried using a bat file in Task Scheduler using C:\Program Files (x86)\Synergration\OpenSync\ScheduledTask.BAT that includes;

    C:\Program Files (x86)\Synergration\OpenSync\OSRun.exe <taskname>
    taskkill /IM C:\Quick Books\QBW32Enterprise.exe /F

    and all I ever get is;
    error: could not start quickbooks: -2147220472
    I had this running automated when I first configured OpenSync, and no longer. I have re-authorized Integration Applications after I updated QB to QuickBooks Enterprise: 2020 and it no longer works. I have paid for premium support and email synegration on multiple occasions to no avail. Can someone help me get this working automated again?

    TIA

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.