OpenSync

Home Forums OpenSync Bin reset on Inventory Adjustment

This topic contains 2 replies, has 2 voices, and was last updated by  a.siragusa 1 week, 3 days ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #66135

    a.siragusa
    Participant

    Hi, I’m tryng to ADD an inventory adjustment. It works but the BIN that I write on InventorySiteLocationRef_FullName and InventorySiteLocationRef_ListID is resetted to the parent inventory site when the Open Sync task run.
    Any suggestion?

    Thanks in advance.
    Regards.
    Armando

    #66162

    Yudel Rosales
    Keymaster

    For Invoice, CreditMemo, Check, Bill, ItemReceipt, BuildAssembly, SalesReceipt,
    CreditCardCharge, CreditCardCredit, VendorCredit, Charge, InventoryAdjustment:
    1) For Add /Mod Request, the Site passed with tag will be applied to
    the transactions once it is saved.
    2) If there are more than one
    aggregates, SDK will set Site for all the
    transactions.
    3) Transaction Add / Mod would succeed, even if Site is not specified, but it will set the
    Site to UnspecifiedSite. The SDK response is created with the Transaction Ret, which
    includes the details of Site.
    4) In a transaction, if quantity is negative, then that transaction becomes non-posting, hence
    Site will be treated as an optional field.
    5) For Charge, BuildAssembly, InventoryAdjustment transactions, the Site will be provided
    in header and will be copied to all the Line Items.
    6) For all other transactions, Site will be provided in the Line Items.

    #66340

    a.siragusa
    Participant

    If I write the inventory site + shelf bin on the inventoryadjustment table opensync return the error “An inventory site was expected but a row/shelf bin was selected”. If I write the shelf bin on inventoryadjustmentlinedetails it is overwritten with the parent site (xxxxx:unassigned).
    Any suggesstion?
    Thanks

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.