Home Forums AccessBooks RealTime Could not start Quickbooks.

This topic contains 9 replies, has 6 voices, and was last updated by  tvanek 1 year, 10 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #6984

    gmcintire

    we now have a partitioned drive specific just for quickbooks.

    i am on the computer that is partioned, and have quickbooks maped as the “q” drive.

    so in accessbooks, i clicked on “configure program”, and then “options”.
    on this tab, i checked the box next to “automatically connect to this company file.”
    then i clicked “select company file”, and selected the qbw file on the “q” drive.

    when i click on “populate tables” i get the error “could not start quickbooks.”

    i have tried with the actual qb program both open and closed.

    how do i fix this?

    thanks,

    #7377

    make sure you have enabled the application to automatically connect to the company file even if qb is not running.  this setting in qb is under edit – preferences – integrated application.  you can also take a look at the qbsdklog.txt file to obtain more information about the failure.  this file is located in one of two places depending on the version of windows you are running.  these are:

    windows xp/server 2003
        c:\documents and settings\all users\application data\intuit\quickbooks

    windows 7/server 2008
        c:\program data\intuit\quickbooks.

    #7381

    sethknorr
    Member

    i do not see an option for "connect to the company file even if qb is not running."

    here are the options i do see: (x indicates it was checked)

    [x] allow this application to read and modify this company file
    [greyed out] prompt before allowing access
    [x] allow this application to login automatically
    login as:
    [someuser]

    [x] allow this application to access social security numbers, customer credit card information, and other personal data.

    these are the only options.

    like i mentioned before, this is a network install of quickbooks. so only the database file exists on the network, and the application exists locally. is this possibly the issue? ie. does the application need to be installed on the network location where the database is located to make this work?

    #7382

    you want to select the option "allow this application to login automatically".  you will then need to specify the "login as" user.  this should either the admin user or a user with full control.

    #7387

    sethknorr
    Member

    this is how it currently is configured. the highest level user is selected, which is the master administrator, still no luck. same error. "could not start quickbooks."

    #7389

    the other thing that can cause this error is having multiple versions of qb installed on the machine.  multiple versions of qb are no supported as the qb api will not reliably connect to a specified company file.  this problem can also be caused by a corrupted qb installation.  in order to correct these problems follow these steps:

    1.  uninstall all versions of qb
    2.  delete the folder c:\program files\common files\intuit
    3.  reinstall the single version of qb you wish to use and download all updates for it

    #7416

    Anonymous

    similar subject was being discussed at yahoo answers last week. i can post the link if needed.

    #7417

    gmcintire
    Participant

    i was having trouble getting abrt 7.0.45 to connect to qb enterpise 2012 to do batch command line refresh – error occurred after process worked for months.  error in abrt log said couldn’t connect to qb.  hope this helps.

    see:

    http://www.pervasive.com/solutions/supp … posts.aspx

    "i was recently informed by intuit suppor that a new feature added to qb for 2011 was the ability to keep qbw32.exe running for a faster qb startup. the problem that arises in this is that qb only allows one instance of qbw32.exe to be running on a single system. when datasynch runs, it makes its own connection to quickbooks. so, if qbw32.exe is open and then datasynch tries to run, the connection to qb would fail because qbw32.exe is already open."

    "there is, however, a way to turn off this feature so it doesn’t happen every time you close qb. if you login to qb and go to edit > preferences > general, you will see a checkbox option for "keep quickbooks running for quick startups". if you uncheck the box next to this option, it will close qbw32.exe every time qb is closed, which is the preferred option when using pervasive datasynch."

    #15068

    tvanek
    Participant

    I wanted to follow up on this post since it caused MAJOR headaches for us in our environment. Our team lost about 2 days to diagnosing, understanding, and solving this problem.

    We had opted to setup several tasks using the Windows Task Scheduler and batch files using the “OSRun.exe task_name” format. When configured to run in Windows Task Scheduler, however, we were seeing this same error about being unable to start an instance of QuickBooks.

    We followed the instruction of turning off the “QuickBooks > Edit > Preferences… > General” option to “Keep QuickBooks running for quick startups. When we did this, we FINALLY got our first task to run as a configured Windows Scheduled Task. But our success was short-lived when the 2nd attempt to manually run the same job through the Windows Task Scheduler failed. It failed because the first task ran and completed just fine, but left an orphaned QBW32.exe process running on the server.

    It looks like OSRun.exe is NOT properly ending the QBW32.exe process it might spawn in order to execute the configured task. As a result, the QBW32.exe proc remains running after the job has completed, impeding the start of the next task.

    In order to get around this, we added a few additional actions to our Windows Scheduled Task.

    Once we configured our Windows Scheduled Task in this manner, our tasks were running just fine.

    Caveat of this, of course, is that any deliberately opened QuickBooks window on the system will be forced to close when tasks complete. Not a big problem for us in our environment, but others may not be so lucky.

    We would have opted to use the OpenSync task scheduler…. but… it has some issues. Namely, there’s no “Start Date” (only time) that can be configured for new tasks. As a result, OpenSync’s task runner (“OSRunner.exe”) will kick off ANY new scheduled tasks because it think that they are overdue to run. We observed this right away and realized we couldn’t have this happening in our production environment, so we went the route of using Windows Scheduled Tasks instead.

    So Synergration Staff, I think you probably need to do one of two things here to mitigate the issue.

    First, you could fix “OSRun.exe” so that it will properly end any “QBW32.exe” task that might be spawned to complete a Windows Scheduled Task.

    Second, you could fix your own Task Scheduler so that tasks can have a “Start Date” to prevent them from being executed ahead of schedule on a start of the scheduler service.

    Thanks,
    Tyson

    #15069

    tvanek
    Participant

    For the record, “OSRunner.exe” (OpenSync’s own scheduled task agent) seems to close that “QBW32.exe” process just fine. It’s only “OSRun.exe” that seems to leave it hanging around.

    -Tyson

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.