Home Forums OpenSync QuickBooks Hangs After Refresh Tasks Complete

This topic contains 2 replies, has 3 voices, and was last updated by  john15 11 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #15777



    We recently ran into an issue where QuickBooks hangs as the Refresh Tasks completes when QuickBooks is closed. We recently upgraded from QuickBooks Enterprise 2015 to QuickBooks Enterprise 2017. We also updated OpenSync to the latest 2.0.80. We did run a repopulate and even re-added the company file.

    Previously, we were using the command line tool and it was working fine. We decided to upgrade QuickBook Enterprise 15 to 17. After we upgraded, we ran into issue where other work stations would experience slowness as the task would complete. We noticed that when we use the gui version, OpenSync says it’s refreshing the last table and QuickBooks on the workstations would hang until OpenSync finished refreshing. Afterwards, everything resumes.

    We also noticed, that if we leave QuickBooks logged in and open, this issue won’t happen. Due to some circumstances, we wish not to leave QuickBooks logged in. Anyone run into this problem and have a solution?

    I did find a post about QuickBooks Enterprise R5_78 was having issues and we already patched to R5_84. Here are the references to what I’m talking about:



    You should not leave QB open on the machine running OpenSync as this can cause updates to be missed due to a bug in the QB API. Also, make sure that you disable the preference in QB to “Keep QuickBooks running to enable faster startups”. If the slowness continues, check the QuickBooks and OpenSync logs to try and narrow down where the time is being consumed.



    I too am having osrunner get stuck and will error that quickbooks is already open and using a different company file (and its not), killing qb32.exe and manually running the task gets it back on track though for awhile.
    I just turned off the preference mentioned and will report back if this resolved my issue as well.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.