OpenSync

Home Forums OpenSync ERROR object variable or with block variable not set

Tagged: 

This topic contains 14 replies, has 2 voices, and was last updated by  Yudel Rosales 2 months, 2 weeks ago.

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #16521

    James Andrews
    Participant

    Hi, need some assistance in correcting an error when UPDATING the Vendor table to Quickbooks using OpenSync. We now receive this error “object variable or with block variable not set” and nothing is updated. We can ADD new vendors to QuickBooks and it works – just can’t seem to update anymore.

    I have populated the Vendor table from Quickbooks to the database and it works. But if I add a STATUS of “Update” to any row on the table and try to “Update Quickbooks” ( no other changes to the data) it fails with this error. Really need this corrected.

    We have moved our installation to a new server, and updated both Quickbooks and Opensync to the latest version.

    Setup :
    Windows Server 2012 R2 Standard. (we are connecting to a remote session)
    Quickbooks 2017 Premier Edition
    OpenSync 3.0.12 (checking for update says this is the latest version – but it still offers to download every time I check for the update)

    I have attached the log files and a Update trace. But I cannot determine the what is generating the error or how to solve it. Any assistance would be helpful. I have searched the forum for fixes to this error – but the few that I found didn’t resolve the issue. I have rebooted, Rebuild the Quickbooks company file and tried a few other things as well.

    Thanks

    Attachments:
    You must be logged in to view attached files.
    #16523

    James Andrews
    Participant

    ..renamed files types from .log and .xml to .txt so the would upload to the forum..

    Attachments:
    You must be logged in to view attached files.
    #16529

    Update is detecting one error. Can you check the error table in your database please?

    #16531

    James Andrews
    Participant

    Yes – the error is the title of the post. Error 91 “object variable or with block not set”

    #16532

    OpenSync main windows go to File and checked “Enable Terminal Server Patches”. Then run your task. please let me know if it works.

    #16533

    James Andrews
    Participant

    I tried that. It didn’t fix the error. Still unable to update the vendor table.
    I am able to add new entries if the status is set to “add”. But if set the item to “update” then I get the stated error

    #16534

    are those records in QuickBooks already? If those records were modified in QuickBooks, you need to refresh the vendor table before to update the records in QuickBooks. Also, make sure that you are closing QuickBooks.

    #16535

    James Andrews
    Participant

    The first thing I did was to clear the vendor table and did a populate from Quickbooks task. The data in the vendor table all came from quickbooks. But if simply change the status of one row in the vendor table to “update” then I get the error. Do I need to remove the edit sequence or any other data to make the update work? again I can “add” entries from the vendor table to Quickbooks but I cannot update those entries after I have added them

    #16575

    James Andrews
    Participant

    Hi. So any solution to this? I still haven’t got it working and really need it fixed. Thanks

    #16607

    Hello James. We were able to recreate that issue. We are working on the solution. We will have a new build by the end of the week. Sorry for the inconveniences.
    Best Regards,

    #16608

    James Andrews
    Participant

    Thanks for the update. Our business looks forward to the solution.

    #16757

    James Andrews
    Participant

    Has the update to fix this been released yet? Can you please let me know where this stands? Thanks

    #16758

    we are still working on it. I will keep you posted. Sorry for inconveniences.

    #17120

    James Andrews
    Participant

    Has there been an update to this yet?????? Per the previous post from August 15,2017 “Hello James. We were able to recreate that issue. We are working on the solution. We will have a new build by the end of the week. Sorry for the inconveniences.
    Best Regards,” Its been over a month now…
    Thanks for any info you can please share with your customer on this…..

    #18825

    The build that corrects that issue was released. Sorry that you didn’t get the notification.
    Download link: http://download.synergration.com/opensyncv3/opensync3.msi

Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.