OpenSync is a 32 bit application and therefore requires the 32-bit MySQL ODBC connector. You can use any version greater than 5.1. If running on a 64-bit version of Windows we have had reports from users saying that they needed to uninstall the 64 bit connector before installing the 32 bit version.

Posted in: OpenSync